Table of Contents

Requirements

Last updated on June 24, 2021

CoreResources requires your server to be installed with the following:

Server Requirements

  • PHP version 7.0.0
  • An updated WordPress installation

Although CoreResources will run on PHP 7.0.0, we recommend at least PHP 7.2 or greater.

Upgrading PHP

If your server does not meet the PHP requirement of CoreResources, you should probably upgrade your PHP version. You can do this yourself or you can ask your hosting company to do this for you. If you don’t know how to ask this to your hosting company, the WordPress documentation keeps a standard letter available that you can send to your hosting company.

We also wrote an article that discusses some tools and background information on keeping your PHP version up to date.

What is an Updated WordPress Installation?

This is not a hard metric, but we aim to make CoreResources work at least with the latest stable version of WordPress. In reality, CoreResources works very well on less recent versions of WordPress as WordPress tends to be largely backward compatible.

Do I need any other plugins installed?

No, CoreResources is a stand-alone plugin. There are no dependencies on any other plugin or theme.

Related Articles